The Q&A Archives: No Blooms

Question: I have a crown imperial that has been in my garden aprox. 5 yrs. and has never bloomed. Usually it gets frosted. This year was a particularly warm spring. I covered the plant and still no blooms. The foliage is thick and I divided it by accident one year when moving it to a different location.

Answer: Crown imperial is a fritillaria and needs both a heavy mulch in winter and a very well drained location, although it appreciates some soil moisture when it is growing. It does best in a rich, friable soil and should be planted where it will not be crowded by other plants. The foliage should be allowed to ripen naturally each year so that it can replenish the bulb and build its strength to bloom; be sure you don't remove the foliage until it has completely withered. the bulb should only be transplanted when dormant, right after the foliage dies back. If the foliage seems healthy then it may simply be a matter of time. It may be that your bulb has taken some time to settle in after transplanting and is not yet of blooming size. It might also need a richer soil. Another possibility is that it needs to be planted deeper -- they should be about eight to twelve inches down!

« Click to go to the homepage

» Ask a question of your own

Q&A Library Searching Tips

  • When singular and plural spellings differ, as in peony and peonies, try both.
  • Search terms are not case sensitive.

Today's site banner is by Char and is called "'Diamond Head' Sunrise"