The Q&A Archives: Red Riding Hood Mandevilla

Question: My mandevilla was doing very well in its 1st year other than some mites which were eating the leaves, but I was able to destroy them in the fall. It was blooming beautifully and growing rapidly until late fall, early winter. Florida winter has been unusually mild, no frost here yet, temps averaging mid 70's and are still in the 80's most days. But, my plant looks sick...trying to flower (couple of blooms, but lost many leaves and looks terrible. I don't dare fertilize (last done mid Nov with slow release granular). It doesn't look like I have mites, although some tips of leaves look brown. It has water from irrigation weekly. Any ideas?

Answer: Bob,

I apologize for this delayed reply to your gardening question and hope it is still helpful to you.

Based on your description it seems that your Mandevilla may have been suffering from soggy wet soil conditions. This prevents the roots from receiving adequate oxygen for periods of time and thus leads to their decline and often to root rot diseases. Hopefully the conditions have improved and the plant recovered be now but if left too long such conditions will be fatal to a plant.

Thanks for the question. Best wishes for a wonderful gardening year in 2007. Please stop in again soon!

« Click to go to the homepage

» Ask a question of your own

Q&A Library Searching Tips

  • When singular and plural spellings differ, as in peony and peonies, try both.
  • Search terms are not case sensitive.

Today's site banner is by Char and is called "'Diamond Head' Sunrise"