Plumeria forum: Help I.D....was supposed to be a white...no foliage on cutting

Views: 128, Replies: 3 » Jump to the end
San Diego (Zone 10a)
Plumerias Roses Region: California
Image
Mark619
Aug 11, 2014 1:15 PM CST

Thumb of 2014-08-11/Mark619/4b2c30

Name: Hetty
Sunny Naples, Florida (Zone 10a)
Plumerias Photo Contest Winner: 2015 Charter ATP Member I was one of the first 300 contributors to the plant database! Garden Ideas: Master Level Plant Database Moderator
Forum moderator Region: Florida Cat Lover Garden Sages Cactus and Succulents Tropicals
Image
Dutchlady1
Aug 11, 2014 1:16 PM CST

Moderator

Did you say cutting? Does it have roots?
San Diego (Zone 10a)
Plumerias Roses Region: California
Image
Mark619
Aug 11, 2014 1:19 PM CST
Dutchlady1 said:Did you say cutting? Does it have roots?


No roots yet...cutting only but the inflo had flowers open up..
Name: Hetty
Sunny Naples, Florida (Zone 10a)
Plumerias Photo Contest Winner: 2015 Charter ATP Member I was one of the first 300 contributors to the plant database! Garden Ideas: Master Level Plant Database Moderator
Forum moderator Region: Florida Cat Lover Garden Sages Cactus and Succulents Tropicals
Image
Dutchlady1
Aug 11, 2014 1:26 PM CST

Moderator

Well it's clearly not white Hilarious! but I think it's pretty. I suggest you cut off the inflo to help it root.

« Garden.org Homepage
« Back to the top
« Forums List
« Plumeria forum
You must first create a username and login before you can reply to this thread.

Today's site banner is by ge1836 and is called "Pacific Blue Ice"