Non-Blooming Azalea - Knowledgebase Question

Anacortes, WA
Question by ddhall
May 29, 2005
We have a deciduous azalea in a container that is lush with new growth but failed to flower this year... it is the second year we've had it in this location but last year (the first year) it was in bud when we purchased it from the nursery. Any idea why it would appear so healthy but fail to produce any flowers?


Image
Answer from NGA
May 29, 2005

0

The most common causes for non-blooming are plant immaturity, poor pruning, improper exposure to sunshine, and over-fertilization. If your azalea flowered the year you purchased it, it's obviously old enough to bloom. Azaleas develop flower buds during the summer months for the following spring's display. If you pruned in late summer or early spring, you may have pruned all the flower buds off. If you didn't prune at all, then perhaps the exposure to sunshine is not quite right. Some azaleas grow best in full shade, others in full sun. You'll need to determine which one is best for your particular plant (the tag should indicate the exposure it requires). Finally, too much nitrogen can result in lush green foliage, at the expense of flowering capability. Don't fertilize your azalea until it finally produces flowers. And when you do fertilize, use a food with a 1-2-1 ratio of nitrogen, phosphorous and potash (5-10-5 is an example). Best wishes with your plant!

You must be signed in before you can post questions or answers. Click here to join!

« Return to the Garden Knowledgebase Homepage

Member Login:

Username:

Password:

[ Join now ]

Today's site banner is by sunnyvalley and is called "Hibiscus 'Purpureus Variegatus'"