Growing Passion Fruit - Knowledgebase Question

Kissimmee, FL
Question by medavis81
June 5, 2005
I have a passion fruit vine i had transplanted last year into a pot. I just moved and was able to find a nice place to plant the vine. It has grown almost five feet and is covered in purple blooms. The problum is the blossom drops off and all thats left is an empty steem. I would really like to know what Im doing wrong? Thank you for your help. Michael Davis, Florida.


Image
Answer from NGA
June 5, 2005

0

Michael,

I am sorry for this delayed reply to your gardening question. We are transitioning to a new Q&A system and your question was unfortunately lost in the transition. I have discovered it now and hope this reply is not too late to be of help.

If you mean that the plant does not set fruit, this is normal with many types of passion vine. If the bloom buds are dropping before they open then this is not normal. The only cause of bloom drop prior to opening is some insect damage while still in the bud. Thrips may be a cause. Products containing Spinosad are a natural, effective option for controlling thrips.

I suggest you also contact your local Extension Office to see if they have any additional suggestions or can look at a photo or a plant sample to help with the diagnosis.

Thanks for the question. Please stop in again soon!

You must be signed in before you can post questions or answers. Click here to join!

« Return to the Garden Knowledgebase Homepage

Member Login:

Username:

Password:

[ Join now ]

Today's site banner is by joannakat and is called "Two poppies (Icelandic and California)"