Non-blooming Climatis - Knowledgebase Question

South Glastonbury, CT (Zone 5B)
Question by cbreen24
June 20, 2005
I just planted a Climatus about a month ago (mid-May) and it bloomed about 6 blossoms soon after it was planted, however, the petals fell off rather quickly and I am not seeing any new potential blooms. Most of the leaves are dark green and the vines are dark, almost brown, the newer, smaller growth is all a light green. My neigbors Climatis hasn't bloomed yet, is much smaller, yet has many small 'pods'. Am I doing something wrong? I beleive it mostly dappled sun, but full late afternoon sun. Is this enough for it to bloom?


Image
Answer from NGA
June 20, 2005

0

Most clematis bloom early in the season and then may form buds for a second flush of blooms, or form the occasional bloom, later in the season. To some extent it depends on what kind of clematis you have and how it was pruned earlier this year as to whether or not yours would rebloom this summer.

Clematis usually take several years to become well established and bloom to their full potential. In the beginning they use most of their energy to build a good root system. So the first few years' blooming will not be as heavy as you would see on an established plant. Also, your plant may be a bit ahead of the season if it was overwintered in a greenhouse for instance, or raised in a warmer part of the country. So it might not bloom at exactly the same time as local plants of the same cultivar.

New growth is usually a bit lighter green than the older foliage, but it should not be yellow or striped with yellow and green. Overall, I think what you are seeing is probably normal. Good luck wiht your clematis!

You must be signed in before you can post questions or answers. Click here to join!

« Return to the Garden Knowledgebase Homepage

Member Login:

Username:

Password:

[ Join now ]

Today's site banner is by Paul2032 and is called "Daisy with bug"