Mandevilla won't bloom and is dropping buds - Knowledgebase Question

Camillus, NY
Question by pmackind
July 10, 2006
Hi, I e-mailed you last week regarding my Tango Twirl Mandevilla. I live in zone 5 and planted the mandevilla (after hardening it for one week)at the end of May. It's now nearly the middle of July. The plant/vine looks healthy and has a good amount of buds but now many of the buds are turning brown and are falling off. In your last reply you said that the buds may not have opened yet due to the cool patch of weather we had. It is now the middle of summer and I'm afraid I won't be getting any flowers at all. What would account for the buds dropping off? I have not overwatered or underwatered the plant. Has anyone else in my area had these problems? Would I be better off with a different type of Mandevilla, not a double flowered plant? Thanks for your help.


Image
Answer from NGA
July 10, 2006

0

When buds turn brown and drop, it is often a sign of either cold exposure, or underwatering. Mandevilla needs soil that is evenly moist (but not sopping wet) during the growing months. If that doesn't seem to be the problem, there may be an infestation of thrips or possibly a fungal infection such as botrytis. There might also be a nutrient imbalance contributing to stress the plant. I would suggest you work with your local county extension to trouble shoot the problem. If it is something that would require a chemical control, they will have the most up to date information on what ot use and how/when to use it.

You must be signed in before you can post questions or answers. Click here to join!

« Return to the Garden Knowledgebase Homepage

Member Login:

Username:

Password:

[ Join now ]

Today's site banner is by Whitebeard and is called "Delosperma cooperi"