non blooming impatiens - Knowledgebase Question

novi, mi
Question by vkandersonx3
July 12, 2006
Impatiens in my back yard are not doing so well along a shady tree border area. Why? Is it the deep shade, soil or fertilizer? I put in a border along my shade to deep shade area, the part the goes towards the deep shade has no blooms and is not doing well. The soil is good topsoil since this is a natauralized tree area. Also I have the same impatiens planted in and around the base of my oak trees with my hostas and snow on the mountain that is doing just beautifully very near and in the same deep shade area? Any suggestions?


Image
Answer from NGA
July 12, 2006

0

If similar plants are doing well in similar light exposure, I'd suspect the soil isn't quite right for the non-blooming impatiens. Perhaps it doesn't drain as well, or maybe the pH is different. Are there roots from other plants nearby that might be competing with the impatiens for moisture and nutrients? I'd investigate further, even to the point of digging one of the plants up and transplanting it to another area of the garden. If it thrives, the soil in the old spot is suspect. If it continues to act as the others, it may be nearing the end of its natural life. Wish I could offer more insight!

You must be signed in before you can post questions or answers. Click here to join!

« Return to the Garden Knowledgebase Homepage

Member Login:

Username:

Password:

[ Join now ]

Today's site banner is by sunnyvalley and is called "Rose Mind Games"