Camellia - Knowledgebase Question

Los Angeles, CA (Zone 10)
Question by jdrane
April 25, 2007
I planted an unknown type camellia bush approximately 1 year ago. To date I get plenty of buds but very few of them open, they start to turn brown before they open and once opened, they are partially brown and are never very large. Can you tell me what the problem is even though I don't know the name of my camellia bush?


Image
Answer from NGA
April 25, 2007

0

It's possible your camellia has Petal Blight Disease. This fungus (Sclerotinia camelliae) attacks mostly the flower petals, but also is a concern on the leaves if severe. The best control is sanitation. Remove all fallen flower petals immediately and dispose of them. They are a source for fungal spores that reinfect the plant. Replace the mulch every year and make sure your camellia has good air circulation all around so the leaves and petals dry off quickly after a rain. This disease is very weather dependent. I have had the same problem and some years it is worse than others. This year I don't see a trace of the disease, but it depends on your local weather. Warm, humid conditions are very conducive to the development of this fungus. Don't fertilize, because it's already stressed, but do prune back the dead stems (to encourage new, healthy growth). Water well once each week and wait to see what happens later in the season.

Best wishes with your camellia

You must be signed in before you can post questions or answers. Click here to join!

« Return to the Garden Knowledgebase Homepage

Member Login:

Username:

Password:

[ Join now ]

Today's site banner is by bootandall and is called "Aster"