First Year Planting Roses - Knowledgebase Question

Merced, Ca
Question by ysabel_espin
August 19, 2008
I planted some roses in the Spring and now they have yellow and brown leaves that don't fall by themselves, hardly any buds and no new growth. I gave them rose food twice as per directed on the label. They are planted in an area where is there isn't morning sun but afternoon. What did I do or what can I do? Please help.


Image
Answer from NGA
August 19, 2008

0

No new growth indicates the plant is not happy in its current location. My best advice is to move them to a sunnier spot in your garden. Before digging them up, prepare the new planting bed by amending the soil with organic matter and digging it in to a depth of 8-10". I usually prepare new beds by digging out any vegetation and then spreading 4-5" of compost or aged manure over the bed, then digging it in with a shovel. Amending the soil will loosen it, help it hold moisture and provide some nutrients for the roots. After you've amended the soil dig individual planting holes for your roses and set them in their new homes. Then water them in well to help settle the soil. Give them 2-3 weeks to become established and then prune off all the sickly looking stems and branches. The new growth it produces should be healthy and your roses should be much happier. Hope so!

You must be signed in before you can post questions or answers. Click here to join!

« Return to the Garden Knowledgebase Homepage

Member Login:

Username:

Password:

[ Join now ]

Today's site banner is by Whitebeard and is called "Delosperma cooperi"