Ask a Question forum: Jasmine suddenly doing poorly

Views: 183, Replies: 1 » Jump to the end

kshaw921
Apr 4, 2017 7:47 PM CST
I planted 4 jasmine plants eight months ago and they have done very well and grew quickly and have been healthy. About two weeks ago I noticed the leaves and vines starting to brown and fall off. I can't figure out why they would suddenly take a turn for the worse. I don't see any evidence of bugs (holes or bugs under the leaves) or fungus. They have seemed to get adequate water. Any suggestions on what they might need to save them?
Thumb of 2017-04-05/visitor/40887f
Thumb of 2017-04-05/visitor/9a67ed

Name: Daisy I
Reno, Nv (Zone 6b)
Not all who wander are lost
Garden Sages Plant Identifier
Image
DaisyI
Apr 4, 2017 9:05 PM CST
Welcome!

Can you tell us where in the world these plants are located?

I wouldn't assume your plants are getting enough water - they look pretty dry. Get down there and check the soil under the plants and get back to us.
Life is not a journey to the grave with the intention of arriving safely in a pretty and well preserved body, but rather to skid in broadside, thoroughly used up, totally worn out, and proclaiming...."WOW What a Ride!!" -Mark Frost

Webmaster: osnnv.org

« Garden.org Homepage
« Back to the top
« Forums List
« Ask a Question forum
Only the members of the Members group may reply to this thread.

Member Login:

Username:

Password:

[ Join now ]

Today's site banner is by plantmanager and is called "Blue My Mind"