Site Talk forum: Unable to upload photo to forum

Views: 352, Replies: 13 » Jump to the end
Eastern Massachusetts (Zone 5b)
jsf67
May 16, 2017 5:16 AM CST


I used to be able to upload photos to forum posts. The process now takes the amount of time consistent with transferring the selected photo, but then no link is created in the post being edited and nothing is visible in the Preview.

Did the method change, so what worked before is no longer correct?

I tried both Yesterday and Today and noticed in between that it worked for other people.
Name: Suzanne/Sue
Sebastopol, CA (Zone 9a)
Sunset Zone 15
Plant Database Moderator Region: California Cottage Gardener Roses Irises Clematis
Garden Photography Keeper of Poultry Hummingbirder Bee Lover Butterflies Houseplants
Image
Calif_Sue
May 16, 2017 9:33 AM CST

Plants Admin

Nothing has changed here, mine upload fine.
What happens when you click the 'Upload an Image' at the bottom of each post? Does it create the 'lightbox' link for an image? Have you changed browsers? Are your images being saved as jpegs? @dave can offer other ideas/suggestions.

Thumb of 2017-05-16/Calif_Sue/af091d


My gardening Blog!
Hand sewn wares and vintage finds in my Etsy store. Summer Song Cottage
Eastern Massachusetts (Zone 5b)
jsf67
May 16, 2017 9:41 AM CST
I click Upload an image.

I get a file dialog box, just like longer ago when such things worked.

I select and "open" from that dialog and the "upload an image" button changes to "uploading..." for about the amount of time as when such things worked.

Then it pops back to the message I'm editing with no 'lightbox' link nor any other indication of where the photo was uploaded. But the button has changed to "Add another photo" as if I had added a first one.

I haven't changed anything in my computer nor browser.
Name: Dave Whitinger
Jacksonville, Texas (Zone 8b)
Region: Texas Million Pollinator Garden Challenge Charter ATP Member I was one of the first 300 contributors to the plant database! Permaculture Raises cows
Beekeeper Vermiculture Garden Ideas: Master Level Garden Sages Plant Identifier Avid Green Pages Reviewer
Image
dave
May 16, 2017 10:19 AM CST

Garden.org Admin

Hmm, odd behavior. I haven't changed anything so I'm kind of at a loss. Confused Have you tried a different browser? If it works on a different browser that would be a valuable clue.
Eastern Massachusetts (Zone 5b)
jsf67
May 16, 2017 11:13 AM CST
I'm using Centos Linux. The installer for Chrome has never worked, which pretty much leaves Firefox as the only real browser.

I'll try to test with Konqueror. But I'm not sure it could do the job anyway.

I never used anything other than Linux/Firefox to access this forum in the past.
Name: Dave Whitinger
Jacksonville, Texas (Zone 8b)
Region: Texas Million Pollinator Garden Challenge Charter ATP Member I was one of the first 300 contributors to the plant database! Permaculture Raises cows
Beekeeper Vermiculture Garden Ideas: Master Level Garden Sages Plant Identifier Avid Green Pages Reviewer
Image
dave
May 16, 2017 11:18 AM CST

Garden.org Admin

Posting this with Firefox on Fedora.


Thumb of 2017-05-16/dave/416b65

Name: Dave Whitinger
Jacksonville, Texas (Zone 8b)
Region: Texas Million Pollinator Garden Challenge Charter ATP Member I was one of the first 300 contributors to the plant database! Permaculture Raises cows
Beekeeper Vermiculture Garden Ideas: Master Level Garden Sages Plant Identifier Avid Green Pages Reviewer
Image
dave
May 16, 2017 11:18 AM CST

Garden.org Admin

Do you have any addons that might be blocking javascript code?
Eastern Massachusetts (Zone 5b)
jsf67
May 16, 2017 11:20 AM CST
Using Konqueror, the Upload button doesn't work at all.
Name: Dave Whitinger
Jacksonville, Texas (Zone 8b)
Region: Texas Million Pollinator Garden Challenge Charter ATP Member I was one of the first 300 contributors to the plant database! Permaculture Raises cows
Beekeeper Vermiculture Garden Ideas: Master Level Garden Sages Plant Identifier Avid Green Pages Reviewer
Image
dave
May 16, 2017 12:12 PM CST

Garden.org Admin

Probably Javascript is disabled.
Eastern Massachusetts (Zone 5b)
jsf67
May 16, 2017 12:32 PM CST
Too many other things (including upload of the same photo to other sites) work for it to make sense that Javascript is disabled.

If I understand correctly, there is a directory or similar structure corresponding to
the 2017-05-16/jsf67 that would appear in the link if the link were created.

If the photo were uploaded (as the timing makes it seem) and the failure were in creation of the link, then that directory like thing should exist and should include my many attempts. I can't look at that without guessing the exact constructed name of the file. But I would expect you have some back door to look there and there may be evidence there of my attempts and whatever went wrong.
[Last edited by jsf67 - May 16, 2017 12:33 PM (+)]
Give a thumbs up | Quote | Post #1445255 (10)
Eastern Massachusetts (Zone 5b)
jsf67
May 16, 2017 12:48 PM CST
I uploaded photos to imgur, then copied the BBCode link from there to paste here, hoping that the image (rather than just a link) would appear here. It worked better than I expected. The forum software here modifies the link created by imgur into a link that looks just like the ones created by direct uploads here.

So indirectly I can get photos here. See my post (what I was trying to post Yesterday):
https://garden.org/thread/view...
Name: Dave Whitinger
Jacksonville, Texas (Zone 8b)
Region: Texas Million Pollinator Garden Challenge Charter ATP Member I was one of the first 300 contributors to the plant database! Permaculture Raises cows
Beekeeper Vermiculture Garden Ideas: Master Level Garden Sages Plant Identifier Avid Green Pages Reviewer
Image
dave
May 16, 2017 3:39 PM CST

Garden.org Admin

I think I fixed it. Try again now!
Eastern Massachusetts (Zone 5b)
jsf67
May 16, 2017 3:43 PM CST

Thumb of 2017-05-16/jsf67/23fcbc

It works now.

Name: Cheryl
Texas (Zone 9a)
Region: Texas Greenhouse Plant Identifier Plant Lover: Loves 'em all! Plumerias Ponds
Foliage Fan Enjoys or suffers hot summers Tropicals Garden Ideas: Master Level Garden Sages Million Pollinator Garden Challenge
Image
ShadyGreenThumb
May 17, 2017 6:54 PM CST
Test from Galaxy7Edge .
Nothing. Nada. the "upload an image " button just changes color, that's all. In another thread someone said it could be a bug in the Firefox upgrade. I can post phitos from my phone using the stock internet ap. And its faster, too!
Life is short, Break the rules, Forgive quickly, Kiss slowly, Love Truly, Laugh
uncontrollably, And never regret anything that made you Smile.

« Garden.org Homepage
« Back to the top
« Forums List
« Site Talk forum
You must first create a username and login before you can reply to this thread.

Member Login:

Username:

Password:

[ Join now ]

Today's site banner is by plantmanager and is called "Blue My Mind"