Hibiscus forum: Losing leaves

Views: 296, Replies: 2 » Jump to the end

grillmaster513
Oct 1, 2017 12:10 PM CST
I have a Hibiscus in a pot, and it just recently started losing leaves at an increased rate. Since I first planted it, maybe one or two leaves would turn yellow a day and it was growing a lot. Last couple of weeks, it has been losing an increased number of leaves. It still has some green leaves and a flower every couple of days, but is getting sparse. Any thoughts on the most likely cause?

I was thinking perhaps repotting to a larger pot might help, but thought that it would be tolerant and stay in the smaller pot a while longer.

I am in the Houston area, and it is stored outdoors.
Name: Johnny
Titusville FL. (Zone 10a)
Image
neverdone
Oct 13, 2017 6:58 AM CST

Thumb of 2017-10-13/neverdone/914899


Thumb of 2017-10-13/neverdone/ba6b05


Thumb of 2017-10-13/neverdone/29647e

Name: Johnny
Titusville FL. (Zone 10a)
Image
neverdone
Oct 13, 2017 7:05 AM CST
sorry grill master i for got to adda post. I grow hibiscus at the house here in central fl. zone 10. the guy in the middle is like you discribe even though the ones next to him are doing ok. I fertilize them once a month regularly, and applied liquid fertilizer to the sparse one this morning. I will let you know if it helps. the liquid fertilizer helped some ixora I have growing that were stressed after hurricane Irma. some times its hard to get a reply round here. guess us newbies have to stick together.
[Last edited by neverdone - Oct 13, 2017 7:06 AM (+)]
Give a thumbs up | Quote | Post #1565802 (3)

« Garden.org Homepage
« Back to the top
« Forums List
« Hibiscus forum
You must first create a username and login before you can reply to this thread.

Member Login:

Username:

Password:

[ Join now ]

Today's site banner is by Fleur569 and is called "Neon Anyone?"