Ask a Question forum: Azaleas, etc.

Views: 147, Replies: 1 » Jump to the end
Name: Anna Templeton
Greensboro, NC
annatemplet
May 7, 2018 6:15 AM CST
Hello,

I have a couple of azaleas in my backyard that have never bloomed! They have been there for several years and grow just fine, but no blooms. They get the midday sun, but not much after that. What could be the problem? Also my azaleas in the front yard bloom one at a time??? Is there a way to make them bloom together?

Also, I have four (4) blueberry bushes, which I planted about 5 years ago. They have never produced fruit. I fertilize and mulch, etc., but no fruit. Help!

One more thing...I have a bank of lirope that has multiplied and taking over. I need to rid myself of this stuff, but do not want to use Roundup. Any suggestions short of digging it up?

Thank you!
Name: Philip Becker
Fresno California (Zone 8a)
Image
Philipwonel
May 7, 2018 11:06 AM CST
I'm going to guess that you have sun azalea's. There probably not getting enough sun. Azalea food may help. You my consider moving them to sunnier area.
PH ? could be problem also.

Blueberries, need lots of sun, like full sun all day is best.

Lirope ?🤔??? Do you mean Lirirope ? As in the Lirirope Lilly ?....
You could spray them with straight household bleach. If that doesn't kill them ?🤔??? Start digging 😭!!!

Ttfn
😎😎😎

Anything i say, could be misrepresented, or wrong.

« Garden.org Homepage
« Back to the top
« Forums List
« Ask a Question forum
Only the members of the Members group may reply to this thread.

Member Login:

Username:

Password:

[ Join now ]

Today's site banner is by Fleur569 and is called "One Inch Miniature Orchid "

This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.