Avatar for Debbekayd
May 27, 2018 5:17 PM CST
Thread OP
Grand Haven, Michigan
I got elephant ears last yr. They seem to have something that looks like some type of fungus I have treated it with a fungicide and it still going on. I also have treated them with for insects. I can't figure it out! I love on the edge of Lake Michigan. Some 6. I brought them in my home for the winter months. Please help I'm at a loss!
Image
May 27, 2018 5:31 PM CST
Name: Lin Vosbury
Sebastian, Florida (Zone 10a)

Region: Ukraine Region: United States of America Bird Bath, Fountain and Waterfall Region: Florida Charter ATP Member I was one of the first 300 contributors to the plant database!
Million Pollinator Garden Challenge Birds Butterflies Bee Lover Hummingbirder Container Gardener
Hi Debbekayd, Welcome!

Is it possible for you to upload a photo here so that we can see what the problem looks like?
A photo of the entire plant and pot as well as a leaf, or whatever part of the plant is showing the "fungus", will help determine what the problem might be and then we can offer suggestions as to how to correct it. To upload a picture:

1. Click on the green area at bottom left of the page where it says Upload an Image.

2. Select a photo from your computer to open it and you will see movement as it's downloading and then you will notice symbols and letters that look something like the following: [lightbox]2018-05/debbekayd/1778b7[lightbox]

3. Click on the green area at bottom that says Finished and
~ I'm an old gal who still loves playing in the dirt!
~ Playing in the dirt is my therapy ... and I'm in therapy a lot!


Only the members of the Members group may reply to this thread.
Member Login:

( No account? Join now! )

Today's site banner is by Vals_Garden and is called "Bee and Moonfire"

This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.